Opencore Laptop Issues (WiFi,Battery,MousePad,Audio,etc)

Opencore Laptop Issues (WiFi,Battery,MousePad,Audio,etc)

Hi I just managed to get my first hackintosh semi-working I got Mojave fully installed using OpenCore however I have encountered many issues that I'm struggling to fix.

CPU: Intel i5-8250U

GPU: Intel UHD 620

RAM: 8GB 2400MHZ SODIMM

Motherboard/Laptop model: Toshiba DynaBook Satellte Pro C50-E-102

Audio Codec: Unknown

Ethernet Card: Realtek Gigabit

Wifi/BT Card: Dual Band Wireless-AC 3265

What guide/tool followed: OpenCore with Kaby lake and Mojave https://dortania.github.io/OpenCore-Install-Guide/ https://dortania.github.io/OpenCore-Install-Guide/config-laptop.plist/kaby-lake.html

What parts I got issues with:

I can't get my I2C HID MousePad working even though I have VooDooI2C installed

I also can't get the battery information at all on OpenCore's website there is a link to a couple posts about it however its beyond me and I don't really understand what I'm meant to do (https://dortania.github.io/OpenCore-Post-Install/laptop-specific/battery.html#dsdt-patching)

Audio isn't working

WiFi isn't working

Bluetooth isn't working

Probably more...

What files/config I am using:

ACPI

Drivers

Kexts

Extra Info: Windows and MacOS are on the same drive

Would anyone be willing to guide me through the battery issue and help out with the other issues I'm having :) like I mentioned at the beginning of the post I am brand new to hackintoshing so please bare with me

submitted by /u/futurelucas4502
[link] [comments]
Whatsapp