Getting Stuck on Welcome Screen after Installing Catalina

Appreciate anyone who is able to help with this. I am able to get past the picker, erase hard drive in disk utility, and install Catalina. After the 2nd restart, one of two things happens:

  1. Freezes on the welcome screen. Sometimes I am able to wiggle the mouse and see the shake to find effect, but cannot move the mouse, and eventually the shake effect is gone. Might be able to move the country picker one or two rows with the keyboard before freezing.
  2. Loads a gray/black screen with a spinning pinwheel and stays there.

Before this, I also tried installing directly from a time machine backup of another mac, and was able to fully install but the screen froze up at the login screen similar to the welcome screen. I got the shake effect from the mouse for a few seconds before it completely froze.

Any ideas what may be causing this? I see in Dortania's guide that freezing on the welcome screen is a common problem, but the solution recommended is to use TSC sync Kexts, which the guide says aren't compatible with AMD CPUs, so I'm stumped.

As a side note, Ethernet (Realtek 2.5 gb) is not working for me in the installer despite using the LucyRTL8125Ethernet kext. If anyone knows what may be causing this, please let me know. Luckily I was able to get wifi working for the install.

Parts list can be found here

CPU: AMD Ryzen 7 3700X

GPU: PowerColor AMD Radeon RX 5700 XT

Motherboard: MSI MPG B550I Gaming Edge Wifi - replaced bluetooth/wifi with BCM9435​0 M.2/NGFF​ WiFi Wire​less Card

Using Opencore 6.0.1, installing Catalina 10.15.6

submitted by /u/katiedhuddle
[link] [comments]
Whatsapp