Intel NUC6i5SYH | Catalina | OpenCore 0.5.9

Intel NUC6i5SYH | Catalina | OpenCore 0.5.9

Recently got a NUC6i5SYH, decided to make it my first hackintosh. I’m using OpenCore-Desktop-Guide + Multiboot Guide (Dual-boot macOS + Windows 10 on two disks).

Specs:

  • CPU: Intel i5-6260U
  • GPU: Iris Graphics 540
  • RAM: 12 GB (8+4)
  • Audio Codec: Realtek ALC 283
  • Ethernet: Intel 1219-V
  • WIFI/BT: Intel AC 8260 + BT 4.2
  • BIOS revision: 0072

Woking: Audio jack, HDMI display, ethernet, BT*, HDMI audio*

Not working: WIFI

Things are different from the guide:

  • The audio device under DeviceProperties should be PciRoot(0x0)/Pci(0x1F,0x3). The guide lists PciRoot(0x0)/Pci(0x1b,0x0) as the example. The layout-id works for me is <01000000>.
  • Fixing iGPU performance section doesn’t work for me, although it suggests Skylake CPU could work. igfxfw | Data | <02000000> prevents the system from booting.

*Notes:

  • BT is working by using these kexts
  • HDMI audio initially doesn’t work, I have tried to fix it by adding “hda-gfx = onboard-1” and modifying connector type. Then a post on tonymacx86 brought my attention. By using FakePCIID & FakePCIID_Intel_HDMI_Audio from Rehabman could enable HDMI audio (see my image). There might be a better way to fix HDMI audio but this is the workaround for me.

Next step is to replace WIFI card with BCM94360CS2 + M.2 B+M Key adapter. Will report back when I install them.

https://preview.redd.it/9jlx8nm6y6651.png?width=1920&format=png&auto=webp&s=2d62ece55a7ba71f3397e02a48ad712d27d7a3ef

submitted by /u/swoosh1234
[link] [comments]
Whatsapp