Ethernet and WIFI for 1. MSI MPG Z490i UNIFY

Hi everyone,

I built this following for general purpose and gaming:

  1. MSI MPG Z490i UNIFY (LGA 1200, Intel Z490, Mini ITX)
  2. Intel Core i7-10700K LGA 1200, 3.80GHz, 8-Core
  3. Powercolor Radeon RX 5700 XT Red Devil
  4. Corsair Vengeance LPX 2x, 16GB, DDR4-3200, DIMM 288
  5. 1T Corsair MP600 M.2 2280
  6. 500GB WD Black SN750 Gaming
  7. NZXT H1

I use my MBP 13 i7 for work, and I want to keep it that way.

I stated the build with Gigabyte X570i and a Ryzen 3600x, and it worked, I had it all, unfortunately, I started installing my applications and they all complained about not supporting the architecture, I use some software for numerical analysis and software development tools (e.g. docker), so in less than 24hr I swapped these with the MSI Z490i and i7-10700k.

I manage to install MacOS using OpenCore 6.2, and I like how snappy the system is now, so I'm happy, but, neither the Ethernet nor the WIFI is working, the WIFI I understand, and I may do without, but the Ethernet? really? actually, the WIFI did work but it was completely unstable.

Any hints? workarounds?

I did small research, and it seems that with this motherboard I can't also replace the Wifi card? and that TB3 may not work, should I change the motherboard? other options are the Asus Z490i or Gigabyte Z490i, but I don't want to waist time and money anymore unless there is a certain amount of confidence (I know, I know).

One thing I notice about this motherboard, I updated the bios, and I read about the D.T.M option, which made OpenCore just work, so I'm happy about that, but, then no Ethernet.

I would like also to extend my warm thanks to the community, and all of the helpful nice contributors by code and knowledge here and on other platforms, you guys rock!

submitted by /u/allochi
[link] [comments]
Whatsapp