OpenCore 0.5.9 "This version of MacOS is not supported on this machine!" even after setting valid "Platform-info" settings in config.plist

My config.plist

My Laptop is a HP-Omen 2017 ce00xx

i7-7700HQ
16GB of RAM (Brand Unknown)
M.2 SSD Samsung Generic (MacOS will be installed to this drive)
2.5" 1TB Samsung EVO 860 Pro (Primary Drive with windows)

Intel 630 Graphics + Nvidia 1050 (dGPU, I don't plan to use the 1050)

Realtek 8822 WiFi (Its not supported and I plan to buy a broadcom chip later)

Using refind bootloader to boot it as my motherboard was not able to boot the USB (with or without legacy) before.

submitted by /u/Chengers
[link] [comments]
Whatsapp