ASRock H81 PRO BTC R2.0 | Intel Core i7-4790 | (Coming SOON!) Radeon RX 580 8GB | OpenCore 0.5.9 | MacOS Catalina 10.15.5 | 100% Working

ASRock H81 PRO BTC R2.0 | Intel Core i7-4790 | (Coming SOON!) Radeon RX 580 8GB | OpenCore 0.5.9 | MacOS Catalina 10.15.5 | 100% Working

https://preview.redd.it/sw6q31oafn451.png?width=1917&format=png&auto=webp&s=8a2b4c5ea2826425b27af63e5a9534e8befc360b

First i want to thank @u/kohnor for helping me out for making this possible, also to Opencore and Hackintosh Community as well,

so my AMD RX580 GPU was delayed at shipping due to COVID-19 Pandemic Lockdown, but overall everything is fine and working seamlessly with iGPU HDMI...

btw here's my spec build:

  • i7-4790
  • Asrock H81 Pro BTC 2.0
  • Kingston 8gbx2 DDR3 (1600mhz)
  • Samsung 860 Evo 250gb (T.R.I.M Support)
  • WD Blue 1TB Hard Drive
  • GPU SOON TO ARRIVE: SAPPHIRE NITRO + RX580 8GB

IGPU Works and Accelerated:

(temporarily i use HDMI port with it for now before my GPU comes but it was a smooth as just like a real mac)

Kexts Used:

  • AppleALC
  • Lilu
  • RealtekRTL8111 (uses built-in Internet port)
  • USBInjectAll
  • VirtualSMC
  • WhateverGreen

Issues fixed by u/kohnor

Bios Drive Entry (Very Important)

This motherboard can't find OpenCores .EFI file. So we have to use a Linux distro to find it.

Make sure to unplug all drives except the MacOS drive! It will not work if you don't. This is the guide I followed: https://www.tonymacx86.com/threads/guide-asrock-uefi-boot-fix.174726/

please note you have to change - efibootmgr -c -L "Clover UEFI" -l "\EFI\CLOVER\CLOVERX64.EFI" to

efibootmgr -c -L "OpenCore" -l "\EFI\OC\OpenCore.EFI"

Audio

this motherboard uses (Realtek ALC662 Audio Codec) and the to make this work with AppleALC, change it to alcid=11.

https://github.com/acidanthera/AppleALC/wiki/Supported-codecs

Still working on:

same with u/kohnor i need to map those USB Ports but "USBInjectAll" works perfectly fine. tho i tried to copy large raw files through usb using my external drive and so far i don't encounter any problems with it.

submitted by /u/megs131998
[link] [comments]
Whatsapp