"USB Accessory Needs Power" after Vanilla Catalina install

Hello,

I performed a fresh Catalina install following the Vanilla Guide, and while nearly everything works I get a "USB Accessory Needs Power" error whenever I plug a flash drive, phone, or iPad into a USB port other than my powered hub. All of my USB ports have injected properly using USBInjectAll.kext and the custom SSDT-UIAC I created for my Sierra install. I did not have this issue on Sierra, which makes me wonder if it's related to the change in treatment of the Embedded Controller (EC) documented in the "Current Issues with Catalina" post. I do have to either rename EC0 to EC in my config.plist ACPI/DSDT/Patches or add a compiled SSDT-EC.aml to my EFI/Clover/ACPI/patched folder in order to boot this Catalina build.

Hardware:

  • CPU: i7-4770K (OC to 4.5 GHz)
  • GPU: HD 4600 + GTX 1080 Ti (disabled with -wegnoegpu)
  • RAM: 16 GB
  • Motherboard/Laptop model: Asus Maximux VI Hero (Z87)
  • Audio Codec: ALC1150
  • Ethernet Card: Intel i217V
  • Wifi/BT Card: Fenvi FV-T919
  • What guide/tool followed: Vanilla Guide, custom SSDT-UIAC build using RehabMan's guide, SSDT-EC.aml compiled from here: https://github.com/acidanthera/OpenCorePkg/blob/master/Docs/AcpiSamples/SSDT-EC.dsl
  • What part I got an issue with: See above
  • What files/config I am using: UEFI Drivers (ApfsDriverLoader.efi, AptioMemoryFix.efi, HFSPlus.efi, VirtualSMC.efi), Kexts (AppleALC, IntelMausiEthernet, Lilu, USBInjectAll, VirtualSMC, WhateverGreen)
  • Extra Info:
submitted by /u/EthanII
[link] [comments]
Whatsapp