Sierra Vanilla install using guide - some success but still a few quirks

I've got the ASUS P67 Sabertooth with i7-2600k chip and VisionTek HD 6870. This is my third Hackintosh and I've been running a successful Lion install on this configuration that has ran like a dream. It's just aging out and I need to run some programs that require a newer macOS.

I've installed 10.12.6. I have WiFi with a USB adapter. Everything seems cherry for the most part. It's fast!

BUT a few oddities and I'm stuck after trying a ton of options (I have been working on this for 2 days). I think I keep editing the EFI partition on the boot drive with Clover Configurator, but I'm not even sure I'm ever actually booting off that.

Here's my main issues:

- I can only boot in either UEFI USB mode OR I can boot in UEFI "Mac OSX" (named by BIOS), but only in Legacy ROM mode (set in BIOS) and ONLY if the USB drive is in. If it's not in, it bounces back to the BIOS. If I set BIOS to UEFI mode, it bounces back to BIOS.

- The other issue is that when I boot off USB, unless I boot in -v mode, I get a prohibited sign. The only issue verbose seems to show is an OsxAptioFix2Drv: Starting overrides for System\Library\CoreServices\boot.efi
Using reloc block: yes, hibernate wake: no. After which the screen flashes, and I'm at my Sierra login. I have tried removing this file and/or replacing with osxaptiofixdrv, but this is on the EFI of the boot drive so I'm not 100% sure it's loading.

This issue is intermittent too, sometimes I restart and load Clover and it boots fine, but most of the time, I have to use -v mode, especially if I remove the USB drive and replace.

I have booted successfully off the Mac OSX boot option in the BIOS but ONLY if the USB drive is in. If it's not, I bounce back to the BIOS.

Thanks for any help.

~ e

submitted by /u/thewatchtrunk
[link] [comments]
Whatsapp